Search Order Functionality Unavailable

Incident Report for Airtrade

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 12:50 CEST

Identified

We are currently experiencing an issue with the search order functionality in our B2B MyFareFinder application.
Our team is actively investigating the cause and working to resolve the problem as quickly as possible.

We will provide an update as soon as more information is available.
Posted Sep 18, 2025 - 09:58 CEST
This incident affected: Applications (MyFarefinder).