Power BI issues

Incident Report for Airtrade

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 21:41 CEST

Identified

Power BI performance degraded due to unexpected background system activity.
Issue under investigation with Microsoft
Posted Oct 08, 2025 - 09:35 CEST
This incident affected: Providers (Microsoft Fabric).