Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2025 - 06:00 CET
Scheduled
We will perform our bi-weekly release to our live environment. This release contains new features, some technical and stability improvements and regular bugfixes. Short disruption of our services is expected
Posted Dec 12, 2025 - 10:02 CET
This scheduled maintenance affected: Applications (Farefinder, MyFarefinder, KLM Holidays PKG, Whitelabel Flight Only, Whitelabel Packages, Holidays KLM, Holidays Transavia) and Services (Web API (Shopping), Package Cache API).